Announcement

Collapse
No announcement yet.

Can't download PDF from the store

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't download PDF from the store

    I was going to download my updated SWADE v.5.5 PDF from the Pinnacle store, but for some reason my browser only suggests downloading it in .xml format (and then immidiately cancels the download anyway). Any ideas on how to download PDF properly?

  • #2
    What's worked for me is redirecting back to the downloads list, and then clicking on the file in question again. It usually lets me download it in PDF form then.

    Comment


    • #3
      Thanks, it worked.

      Comment


      • #4
        It hasn't worked for me. I've tried two browsers. Google Chrome and Microsoft Edge.

        Comment


        • #5
          I have the same issue on Chrome and Edge. I didn't try to come back an retry. Actually, I use Firefox for these downloads (or I wait their avaibilty on Drivethrurpg).

          Comment


          • #6
            This might not help, but I use Chrome and have no issues downloading stuff. I click the link and a new tab opens with the pdf in it.
            Like what you have read in someone's post? Hit that like button and let everyone know.

            I run Deadlands Reloaded. One of my players writes an incharacter blog here --> http://ballgownsandbattleskirts.blog...deadlands.html

            Comment


            • #7
              It is sporadic for me. Just downloaded the core book, the companion book, and the archetype set 01, but when I try to download The Cackler book it keeps trying to give me an XML.

              Comment


              • #8
                I was able to download pdf. Got the sheets I needed. It would be easier in pinnacle would just send the download to a email but all good

                Comment


                • #9
                  Originally posted by Aldi View Post
                  It would be easier in pinnacle would just send the download to a email but all good
                  I disagree. Sending a pdf to an email could be ok once. But what if you delete that email?
                  Buying lots of books? At different times?
                  Your inbox is going to fill up very quickly.

                  Whereas having all the purchases in one place (actually two as PEGInc also put everything on DriverthruRPG as well) is much easier for the customer and PEGInc. It's very easy to see if anything is missing, for example, and for PEGInc to fix that.

                  Like what you have read in someone's post? Hit that like button and let everyone know.

                  I run Deadlands Reloaded. One of my players writes an incharacter blog here --> http://ballgownsandbattleskirts.blog...deadlands.html

                  Comment

                  Working...
                  X